System requirements (PHP, SQL, etc.)

On some misconfigured servers, error messages can appear which prevent the menu from normal working. Usually the Smart Slider will show a notice message for you, which will tell what server components are missing. In the following articles I will write all of the components what Smart Slider needs for normal working.

PHP version & components

  • PHP VERSION: The required version is 5.1.4 or higher.
  • Component: GD – Graphics directory. Usually it is enabled on every web-server, but if not, feel free to ask your hosting provider. They will enable it for you.
  • Component: CURL. Only needed when you are using social generators.

SQL type

MYSQL: The required version is 4.0 or higher.

Joomla Versions

Joomla 2.5.x or above: (Technically Smart Slider supports the most popular Joomla versions: Joomla 2.5, Joomla 3.x)

WordPress Versions

WordPress 3.1 or newer

jQuery

jQuery 1.x (1.8.0+)

Server security

Smart Slider 2 slide editor is some kind of HTML editor which means we have to post HTML data to the server. To prevent encoding issues we are posting our datas as base64 encoded string. If you site has base64 security filtering, you will need to disable it to prevent any conflicts. This is only required for backend. On frontend, you can leave the filtering on.

Backend browsers

The Smart Slider backend was tested on Firefox, Chrome and IE10+, so use one of them for the slider creating.